Update Needed for Dell Support Assist

Tomorrow's Internet Solutions Technology

If you are currently using a Dell laptop or desktop that features the Dell SupportAssist application, you might want to quickly check which version you are using. A vulnerability has been discovered in the utility that affects Dell SupportAssist for Business PCs version 2.0 and Dell SupportAssist for Home PCs version 3.2.1 or earlier. Dell has provided an update to …

Remote Desktop Services Remote Code Execution Vulnerability: May 14, 2019

Tomorrow's Internet Solutions Uncategorized

Customer guidance for CVE-2019-0708 | Remote Desktop Services Remote Code Execution Vulnerability: May 14, 2019 On May 14, 2019 Microsoft issued the following statement regarding this security concern: Microsoft is aware that some customers are running versions of Windows that no longer receive mainstream support. That means those customers will not have received any security updates to protect their systems …