Update Needed for Dell Support Assist

Tomorrow's Internet Solutions Technology

If you are currently using a Dell laptop or desktop that features the Dell SupportAssist application, you might want to quickly check which version you are using. A vulnerability has been discovered in the utility that affects Dell SupportAssist for Business PCs version 2.0 and Dell SupportAssist for Home PCs version 3.2.1 or earlier. Dell has provided an update to correct this situation.

Dell Support Assist is an application provided by Dell that updates firmware, drivers and applications on Dell systems. It’s important to update drivers and firmware but this application needs an update which Dell has provided.

This advisory is intended to eliminate a vulnerability that could allow hackers to penetrate the system affected and even take control over the computer.

If you would like assistance determining if your laptop or desktop needs an upgrade, call us at 630/953-3100 or email us at Tg@TomorrowsSolutions.com